PATTERN DISCOVERY TOOL

WORDS VIEWER

ABSTRACT

Summary: WORDS VIEWER is a free software which allows to see the distribution of motifs in a group of nucleotide sequences. It shows the occurrence of words choosen by user in a normalized sequence length, so it is possible to work with sequences of different length. Its graphic interface allows to easily set the parameters that characterize the motifs being sought. This tool handles large data sets and runs on the Windows operative system.

Contact: f.piva@univpm.it

SYSTEMS AND METHODS

WORDS VIEWER is written in Borland Delphi v.6 and runs on ix86 compatible processors under Microsoft Windows as well as on Apple Macintosh, Linux and Unix-based platforms using Windows emulator software with one of the required Microsoft Windows versions.

INTRODUCTION

A large number of genomic sequences have recently become available. Some kind of sequences have a characteristic distribution of motifs, according to their function: e.g. mRNA splicing, RNA folding, DNA bending, DNA stability in case of introns; coding function, splicing, in case of exons; regulation in case of upstream of the 5’ UTR… Other sequence regularities may be involved in other functions like chromatin organization, cell differentiation, regulation of mRNA lifetime, transport, and translation velocity. WORDS VIEWER was developed to show the distribution and localization of motifs introduced by user. It reads both fasta and plain text format files containing one or more sequences to be analyzed. Sequences to analyse can have different length because software normalizes their lengths. The sequences can also be sought by analyzing considering the phase, which is especially useful when investigating coding sequences. In this case it considers that input sequences start from phase 0. By setting a flag, input sequences having nonsense codons in frame can be rejected; this is helpful when input datasets involuntarily contain coding sequences that are not in frame.

A window on the left side of the panel and a bar at the bottom show the progress of the computing and the work that remains to be done.

SYSTEMS AND METHODS

WORDS VIEWER is written in Borland Delphi v.6 and runs on ix86 compatible processors under Microsoft Windows as well as on Apple Macintosh, Linux and Unix-based platforms using Windows emulator software with one of the required Microsoft Windows versions.