PATTERN DISCOVERY TOOL

ABSTRACT

Summary: PATTERN DISCOVERY TOOL is a free software which allows to seek exhaustively patterns both short and very spread, in genomic sequences. User can set the kind of pattern to search: number of words making up pattern, their maximum length, minimum and maximum distance among them. It is very fast because utilizes a buffer to keep data red from input file to minimize accesses to hard disk but also it has been rebuilt and optimized some indexing function to the strings. Its graphic interface allows to easily set the parameters that characterize the motifs being sought. This tool handles very large data sets and runs on the Windows operative system.

Contact: f.piva@univpm.it

INTRODUCTION

A large number of genomic sequences have recently become available. Unexpected patterns could lie in non-genic sequences and this can be demonstrated from the existence of correlations between nucleotides at various distances (Peng 1995). Methods like fast Fourier transform (FFT) or detrended fluctuation analysis (DFA) reveal the presence of nucleotidic relationships but do not show the structures of the motifs responsible for the regularities. Genic sequences also exhibit correlations (Luo 1991, Peng 1995) due to the fact that the aminoacid language does not specify all genic bases. The unconstricted nucleotides do not have random distributions but give rise to regularities known as codon bias and context-dependent codon bias (Fedorov 2002). Degenerate and non-degenerate nucleotides seem to make up a context specifying the information for the splicing process (Pagani 2003). Sequence regularities may be involved in other functions like chromatin organization, cell differentiation, regulation of mRNA lifetime, transport, folding, and translation velocity. In the web there are tools to perform pattern discovery analysis (e.g. http://cbcsrv.watson.ibm.com/Tspd.html) but they are very slow when sequence to analyse exceed some tens. PATTERN DISCOVERY TOOL was developed to reveal correlations between nucleotides also at long distance among them. It reads text both fasta and plain text format files containing one or more sequences to be analyzed. The sequences can have different length and it is not case sensitive. It is possible to set the number of words making up the motiv to search choosing from 3 to 5; the distances among words can be set from 1 to 254 nucleotides. User can choose the tresholds of minimum and maximum frequency to visualize the found patterns and they are shown in real time during computing. A progress bar and a window on the bottom side of the panel show the progress of the computing and the work that remains to be done.

SYSTEMS AND METHODS

PATTERN DISCOVERY TOOL is written in Borland Delphi v.6 and runs on ix86 compatible processors under Microsoft Windows as well as on Apple Macintosh, Linux and Unix-based platforms using Windows emulator software with one of the required Microsoft Windows versions.

ACKNOWLEDGEMENTS

We would like to thank Andrea Martini for helpful comments while developing the program prototype.

REFERENCES

Fedorov A, Saxonov S, Gilbert W. (2002) Regularities of context-dependent codon bias in eukaryotic genes. Nucleic Acids Res. Mar 1;30(5):1192-7.

Luo LF, Li H. (1991) The statistical correlation of nucleotides in protein-coding DNA sequences. Bull Math Biol.;53(3):345-53

Pagani F, Buratti E, Stuani C, Baralle FE. (2003) Missense, nonsense, and neutral mutations define juxtaposed regulatory elements of splicing in cystic fibrosis transmembrane regulator exon 9. J Biol Chem. Jul 18;278(29):26580-8.

Peng CK, Buldyrev SV, Goldberger AL, Havlin S, Mantegna RN, Simons M, Stanley HE. (1995) Statistical properties of DNA sequences. Physica A.;221:180-92