DNA RANDOM SEQUENCE GENERATOR

ABSTRACT

Summary: DNA RANDOM SEQUENCE GENERATOR is a free software which allows to create random DNA sequences setting both their length and the percentage of nucleotide composition. Random number generator of Delphi 6 is used, it guarantees an uniform distribution of random numbers, a good randomness, a long cycle length and a high spped. This tool is useful for Monte Carlo calculations and also to calculate the background score of an alignment. Its graphic interface allows to easily set the parameters and it can generate sequences up to 4 thousand millions in length. It runs on the Windows operative system.

Availability: The software, complete with examples and documentation, is freely available to users from: http://www.introni.it/en/software

Contact: f.piva@univpm.it

INTRODUCTION

A large number of genomic sequences have recently become available. Unexpected patterns could lie in non-genic sequences and this can be demonstrated from the existence of correlations between nucleotides at various distances (Peng 1995). Methods like fast Fourier transform (FFT) or detrended fluctuation analysis (DFA) reveal the presence of nucleotidic relationships but do not show the structures of the motifs responsible for the regularities. Genic sequences also exhibit correlations (Luo 1991, Peng 1995) due to the fact that the aminoacid language does not specify all genic bases. The unconstricted nucleotides do not have random distributions but give rise to regularities known as codon bias and context-dependent codon bias (Fedorov 2002). Degenerate and non-degenerate nucleotides seem to make up a context specifying the information for the splicing process (Pagani 2003). Sequence regularities may be involved in other functions like chromatin organization, cell differentiation, regulation of mRNA lifetime, transport, folding, and translation velocity. To validate the presumed regularities it is necessary to execute significance tests (e.g. Monte Carlo simulation) using random sequences. The software create and save random DNA sequences of desired length and nucleotide composition in a text file.

SYSTEMS AND METHODS

DNA RANDOM SEQUENCE GENERATOR is written in Borland Delphi v.6 and runs on ix86 compatible processors under Microsoft Windows as well as on Apple Macintosh, Linux and Unix-based platforms using Windows emulator software with one of the required Microsoft Windows versions.

REFERENCES

Fedorov A, Saxonov S, Gilbert W. (2002) Regularities of context-dependent codon bias in eukaryotic genes. Nucleic Acids Res. Mar 1;30(5):1192-7.

Luo LF, Li H. (1991) The statistical correlation of nucleotides in protein-coding DNA sequences. Bull Math Biol.;53(3):345-53

Pagani F, Buratti E, Stuani C, Baralle FE. (2003) Missense, nonsense, and neutral mutations define juxtaposed regulatory elements of splicing in cystic fibrosis transmembrane regulator exon 9. J Biol Chem. Jul 18;278(29):26580-8.

Peng CK, Buldyrev SV, Goldberger AL, Havlin S, Mantegna RN, Simons M, Stanley HE. (1995) Statistical properties of DNA sequences. Physica A.;221:180-92