Home

Correlation Finder

Institute of Biology and Genetic
Polytechnic University of Marche
60131 Ancona

ITALY


About software

CORRELATION FINDER is a free software which allows to seek correlations between nucleotides in genomic sequences.

It computes some parameters for each analyzed correlation: the relative abundance, the conditional probability, the frequency of the words making up the correlation.

It is quite fast because utilizes a buffer to keep data red from input file to minimize accesses to hard disk.

Availability: www.introni.it/en/software

Author: Eng Francesco Piva
f.piva@univpm.it

Institute of Biology and Genetic
Polytechnic University of Marche
Via Brecce Bianche
Monte D'Ago
60131 ANCONA


Glossary

Correlation: Link between nucleotides. There is a correlation between nucleotides when the presence of a particular base (implier) implies or promotes the presence of another particular (implied) base in a different position. If the distance between correlated nucleotides is relatively short (about less than 10), they can have a functional role, for example be involved in a binding site. Long distance correlations in transcription sequences can be involved in mRNA secondary structure.

Codon bias: Preferential codon usage within synonymous groups. Coding sequences are biased in their usage of synonymous codons. It is hypothesised to be a consequence of either mutational pressure or translational selection. Highly expressed genes have a very strong bias, in which only very few codons are systematically used. High bias can confer high translation efficiency to sequences.

Conditional probability (C): probability that the second event B happens given that the first event A has happened or probability of B given A.
C = P(B|A) = P(A and B) / P(A)

Information Theory: Efficiency in a language is the ability to transfer or memorize information using the smallest possible number of symbols, whereas redundancy is the loss of efficiency caused by the presence of correlations and different frequencies of symbols or words. According to the information theory, the more chaotic the succession of symbols of a language, the greater its efficiency but the less robust the language in terms of the ability to preserve/transfer information in the presence of noise. Natural languages tend to reach a balance between efficiency and robustness; redundancy is therefore a characteristic of natural languages.

Language: The protein coding regions of genes are highly constrained by the presence of at least two languages, one specifying the amino acid by defining the codon (coding function) and the second regulating the splicing process by defining some codons among their synonyms; this contributes to the formation of enhancer or silencer regulatory elements which allow exons to be recognized as constitutive or alternative. The two languages are able to coexist because the genetic code is degenerate and the splicing language can use bases that are not constrained by the first language. Since not all exonic synonymous mutations affect splicing efficiency, the splicing language obviously does not specify all synonymous codons and can drive splicing by creating alternative signals with equivalent function. Consequently, other constraints or languages can be present in gene coding sequences. In fact, there is evidence that synonymous codon usage is partly constrained by the isochore composition of the region in which the gene lies. Some codons create motifs to bind proteins involved in transcription, in the export of mRNA towards the cytoplasm, and in translation. In addition, coding sequences seem to be overloaded with functions whereas the opposite is true of introns, as they contain few splicing signals while the rest have a weak regulatory role.

Relative abundance (R): observed / expected motifs ratio. If two events A and B are independent, P(A and B)=P(A)*P(B).
So R = P(A and B) / [P(A)*P(B)] = 1
The more R value is different from 1 the more a correlation between A and B could exist.


License

The software is freely available to academic users.

For other utilization please contact the author.


Installation

Correlation Finder is written in Borland Delphi v.6 and runs on ix86 compatible processors under Microsoft Windows as well as on Apple Macintosh, Linux and Unix-based platforms using Windows emulator software with one of the required Microsoft Windows versions.

Files:

Correlation_finder.exe : Executable file

Correlation_finder.chm : Help file

fasta_input.fas : Example of an input fasta format file

plain_text_input.txt : Example of an input plain text format file

output.txt : Example of an output text format file

You have simply copy files in a folder and run the executable file..


Program use

Correlation Finder was developed to reveal correlations between nucleotides. It reads text both fasta and plain text format files containing one or more sequences to be analyzed and it is not case sensitive. The sequences can have different length. It is possible to set the kind of correlation to search: between triplets; triplet and nucleotide; two consecutive triplets and a nucleotide; two consecutive triplets and another triplet. The user can set the minimum and maximum distance between the words taking part to the correlation being sought. The first sequence can also be sought by analyzing the in frame sequences of the input file, which is especially useful when investigating coding sequences. In this case it considers that input sequences start from phase 0.

Let’s define the motif (xyz,d,w) as a triplet xyz and a nucleotide w at a distance d downstream xyz. For example: (cag,3,a) corresponds to the motif ‘cag..a’.

In case of seek of correlations between a triplet and a nucleotide not considering the phase, the software computes these values:

the frequency of the triplet xyz

the frequency of the nucleotide w

the frequency of the motif (xyz,d,w)

the relative abundance R of the motif (xyz,d,w) as

the conditional probability C as

Max_col: maximum length of each sequence of the input file

Max_row: number of sequences of the input file

In case of seek of correlations between a triplet and a nucleotide considering the phase, the software computes these values:

the frequency of the triplet xyz

the frequency of the nucleotide w

the frequency of the motif (xyz,d,w)

the relative abundance R of the motif (xyz,d,w) as

the conditional probability C as

DIV(a,b) is the integer division without remainder

The program can remove the bias due to the different nucleotide frequency w as a function of the phase. By setting a flag, input sequences having nonsense codons in frame can be rejected; this is helpful when input datasets involuntarily contain coding sequences that are not in frame. Maximum distance d is 60 nucleotides. An output text file is produced showing for each motif: R, C, F(xyz,d,w), Fd(xyz) and Fd(w) values. Windows on the left side of the panel show the progress of the computing and the work that remains to be done.

Example of output file:

xyz d  w   R     C  F(xyz,d,w) F(xyz) F(w)

aaa  1  a  4,7925  0,3818  0,0084  0,0221  0,2373
aaa  1  c  3,3280  0,1501  0,0033  0,0221  0,2443
aaa  1  g  0,4486  0,2247  0,0050  0,0221  0,2561
aaa  1  t  0,6996  0,2434  0,0054  0,0221  0,2623
aac  1  a  1,4852  0,3524  0,0036  0,0101  0,2373
aac  1  c  1,1300  0,2760  0,0028  0,0101  0,2443
aac  1  g  0,2165  0,0554  0,0006  0,0101  0,2561
aac  1  t  1,2049  0,3161  0,0032  0,0101  0,2623
aag  1  a  0,0136  0,2769  0,0045  0,0161  0,2373
aag  1  c  0,8344  0,2038  0,0033  0,0161  0,2443

REFERENCES

Fedorov A, Saxonov S, Gilbert W. (2002) Regularities of context-dependent codon bias in eukaryotic genes. Nucleic Acids Res. Mar 1;30(5):1192-7.

Luo LF, Li H. (1991) The statistical correlation of nucleotides in protein-coding DNA sequences. Bull Math Biol.;53(3):345-53

Pagani F, Buratti E, Stuani C, Baralle FE. (2003) Missense, nonsense, and neutral mutations define juxtaposed regulatory elements of splicing in cystic fibrosis transmembrane regulator exon 9. J Biol Chem. Jul 18;278(29):26580-8.

Peng CK, Buldyrev SV, Goldberger AL, Havlin S, Mantegna RN, Simons M, Stanley HE. (1995) Statistical properties of DNA sequences. Physica A.;221:180-92


Ringraziamenti

Acknowledgments

We would like to thank Andrea Martini for helpful comments while developing the program prototype.